Jump to content

PRX - GateHub - Issue - Fail to Send - DRY_Path


Guest
 Share

Recommended Posts

Problem:

I have two (2) accounts A (Sender) and B (Receiver) at the following addresses:

Sender:

rBX77KGmzg1GkxmSLmSMnmDKyHRuJPdUXv

Recipient: 

rw45kKRcipAJWHADxnjRAfkBQzBR8FfRZm

 

The Sending and Receiving accounts have not been re-configured. They are new and have not been used other than to attempt to send PRX to a recipient that does not have PRX. The sending account uses a wallet with Imported Ripple Trade funds. The Sending address has 49.9 XRP and a lot of PRX. The Sending address is not the Primary Wallet.

My attempt to send... failed the first say 5 times, then succeeded... ONCE.

There after it failed...

The PRX Connector was added to both wallets... the address used was Jon's rPRX... address.

--

This feels like both a software design issue with Ripple... and secondarily... and GateHub or Jon (PRX Issuer) configuration issue. From a user perspective this should never happen.

Suggestion:

  1. I think it is wrong to require 'humans' to understand how to add Trust Lines to their wallets... the humans I know will not do this. They would require the 'provider' (bank or gateway) to have figured this out. If Jon or anyone else were to issue a token, then the proper configuration should be established with GateHub prior to launching. [I am not complaining... this is an experiment... certainly, but it appears that there should be a REGISTRATION Process in GateHub that deals with these issues up front.]
  2. ... I could say more
Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Popular Days

Your trustlines look fine.

Your last transaction from rBX... to rw4... (TXID: 874A0260258E792546B0A79F79B135A8DF09318432B11D5BA60318B80E16934C) failed because you tried to deliver PRX.rw4..., not PRX.rPRX...

I believe that if you had had a trustline from rBX... to rw4... for PRX, you could have sent it given rw4... had issued PRX and rBX... held some.

What you really want to do here is send PRX.rPRX..., not PRX.rw4... - Just make sure your client is sending the correct issuance.

Edited by Guest
Link to comment
Share on other sites

@tomxcs

Thanks I will look into this... I wonder a bit because the SAME configuration worked after some five (5) attempts, then subsequently it failed. I will into this more.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.