Jump to content

Unable to run cmake.. Difficulties with Boost. Ran into this error while running through the "Build and Run Tutorial" on the tutorial page.


luckflos
 Share

Recommended Posts

ubuntu@ip-172-31-69-48:~/boost_1_75_0/rippled/my_build$ cmake ..
-- gch:e32bc674aa2a035ea0f05fe43d2f301b203f1827
-- Using 2 cores for ExternalProject builds.
-- rippled version: 1.9.1
-- NIH-EP cache path: /home/ubuntu/boost_1_75_0/rippled/.nih_c/unix_makefiles/GNU_9.4.0/Release
-- docker NOT found -- won't be able to build containers for packaging
-- BOOST_ROOT: /home/my_user/boost_1_75_0
-- BOOST_LIBRARYDIR:
CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Boost-1.71.0/BoostConfig.cmake:117 (find_package):
  Found package configuration file:

    /usr/lib/x86_64-linux-gnu/cmake/boost_chrono-1.71.0/boost_chrono-config.cmake

  but it set boost_chrono_FOUND to FALSE so package "boost_chrono" is
  considered to be NOT FOUND.  Reason given by package:

  No suitable build variant has been found.

  The following variants have been tried and rejected:

  * libboost_chrono.so.1.71.0 (shared, Boost_USE_STATIC_LIBS=ON)

  * libboost_chrono.a (shared runtime, Boost_USE_STATIC_RUNTIME=ON)

Call Stack (most recent call first):
  /usr/lib/x86_64-linux-gnu/cmake/Boost-1.71.0/BoostConfig.cmake:182 (boost_find_component)
  Builds/CMake/deps/FindBoost.cmake:273 (find_package)
  Builds/CMake/deps/Boost.cmake:47 (find_package)
  CMakeLists.txt:54 (include)


-- Configuring incomplete, errors occurred!
See also "/home/ubuntu/boost_1_75_0/rippled/my_build/CMakeFiles/CMakeOutput.log".
See also "/home/ubuntu/boost_1_75_0/rippled/my_build/CMakeFiles/CMakeError.log".
ubuntu@ip-172-31-69-48:~/boost_1_75_0/rippled/my_build$ ubuntu@ip-172-31-69-48:~/boost_1_75_0/rippled/my_build$ cmake ..
-bash: ubuntu@ip-172-31-69-48:~/boost_1_75_0/rippled/my_build$: No such file or directory
-- BOOST_ROOT: /home/my_user/boost_1_75_0
-- BOOST_LIBRARYDIR:
CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Boost-1.71.0/BoostConfig.cmake:117 (find_package):
  Found package configuration file:

    /usr/lib/x86_64-linux-gnu/cmake/boost_chrono-1.71.0/boost_chrono-config.cmake

  but it set boost_chrono_FOUND to FALSE so package "boost_chrono" is
  considered to be NOT FOUND.  Reason given by package:

  No suitable build variant has been found.
 

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.