Jump to content

Invalid currency/issuer '5852534849420000000000000000000000000000/rN3EeRSxh9tLHAUDmL7Chh3vYYoUafAyyM


roukrak
 Share

Recommended Posts

Hi,

I run a rippled node. When I run the command 'rippled book_offers BTC/rJHygWcTLVpSXkowott6kzgZU6viQSVYM1 5852534849420000000000000000000000000000/rN3EeRSxh9tLHAUDmL7Chh3vYYoUafAyyM' (this is the XRSHIB currency) I get the following error:

{'error': 'invalidParams', 'error_code': 31, 'error_message': "Invalidcurrency/issuer'5852534849420000000000000000000000000000/rN3EeRSxh9tLHAUDmL7Chh3vYYoUafAyyM'", 'rpc': {'method': 'book_offers', 'params': ['BTC/rJHygWcTLVpSXkowott6kzgZU6viQSVYM1', '5852534849420000000000000000000000000000/rN3EeRSxh9tLHAUDmL7Chh3vYYoUafAyyM']}, 'status': 'error'}

 

I also tried to replace it with the currency code "XRSHIB". This does not work either. For other pairs it works perfectly fine. Anyone know what I am doing wrong?

When I run it in the websocket-api-tool of xrpl.org it also works fine.

 

Thanks!

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Are the book offers that work those with only 3 letters? Are you running an updated version of rippled? I wasn't aware that xrpl now supported currencies with more that 3 letters. My God many library implementations would be broken, including my own. 

It's likely a bug. File a bug with rippled. First make sure you're running an updated version

@Sukrim Sukrim might know

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.