Jump to content

1.7.2 upgrade "UTC Application:FTL : bad lexical cast: source type value could not be interpreted as target"


Recommended Posts

I upgraded my node from 1.7.0 to 1.7.2
does not seem to start:
 

| 2021-Jun-04 01:21:42.802957227 UTC LedgerConsensus:NFO Consensus mode change before=observing, after=observing                                                                                                     │
│ 2021-Jun-04 01:21:42.802973229 UTC JobQueue:DBG addRefCountedJob : Adding job : reportConsensusStateChange->pubConsensus : 9                                                                           │
│ 2021-Jun-04 01:21:42.802990878 UTC NetworkOPs:DBG Initiating consensus engine                                                                                                                                                        │
│ 2021-Jun-04 01:21:42.803147213 UTC Application:FTL Unable to setup server handler                                                                                                                                                    │
│ 2021-Jun-04 01:21:42.803159233 UTC Application:FTL : bad lexical cast: source type value could not be interpreted as target                        

 

Any help would be appreciated

Link to comment
Share on other sites

  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

That’s curious. It looks like you may have something unexpected in your config file, potentially in the stanzas that configure the server ports.

Link to comment
Share on other sites

Here are my ports from the config.
They appear to be straight forward.

[port_rpc_http]
port = 5005
ip = 0.0.0.0
protocol = http
user = ${RPCUSER}
password = ${RPCPASS}

[port_peer]
port = 51235
ip = 0.0.0.0
protocol = peer

[port_websocket]
port = 5006
protocol = ws
ip = 0.0.0.0
permessage_deflate = false

do you see anything off here?

Link to comment
Share on other sites

On 6/5/2021 at 10:19 AM, 0xf said:

Here are my ports from the config.
They appear to be straight forward.



[port_rpc_http]
port = 5005
ip = 0.0.0.0
protocol = http
user = ${RPCUSER}
password = ${RPCPASS}

[port_peer]
port = 51235
ip = 0.0.0.0
protocol = peer

[port_websocket]
port = 5006
protocol = ws
ip = 0.0.0.0
permessage_deflate = false

do you see anything off here?

I assume that ${RPCUSER} and ${RPCPASS} are placeholders to avoid revealing your username and password?

That looks fine. Can you show more of your configuration file perhaps?

Link to comment
Share on other sites

you are correct on the placeholders :)
this is the rest

[node_size]
medium

[ledger_history]
full

[node_db]
type=RocksDB
path=/opt/ripple/data
open_files=2000
filter_bits=12
cache_mb=256
file_size_mb=8
file_size_mult=2
advisory_delete=0

[shard_db]
path=/opt/ripple/data/db/shards/nudb
max_size_gb=500

[database_path]
/opt/ripple/data

[debug_logfile]
/opt/ripple/data/debug.log

[sntp_servers]
# time.windows.com
time.apple.com
time.nist.gov
# pool.ntp.org

[validators_file]
validators.txt

[rpc_startup]
{ "command": "log_level", "severity": "info" }

[ssl_verify]
1

# this needs to remain the end of the file because the list of peers is appended during build time
[ips_fixed]

 

Link to comment
Share on other sites

  • 3 weeks later...

I’m at a bit of a loss. Nothing obviously stands out from what you’ve shown.

And to confirm, you’re saying that without any other changes from your end, 1.7.0 worked but 1.7.2 is giving you the “bad lexical cast” error?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.