Jump to content

Secret key


Recommended Posts

2 hours ago, Mercury said:

If your feeling trustworthy maybe share your secret key with someone and see if they can make it work. If they can you can always move the funds to a new wallet

NO. Please NEVER suggest this.

Link to comment
Share on other sites

There are a few possibilities I can think of:

1) Maybe one tool is interpreting the string as a seed (and decoding it) and the other is interpreting it as a brain wallet string (and hashing it).

2) Maybe the tool supports more than one way of going from secrets to keys, like some HD scheme, and doesn't show this very clearly in its UI. Maybe the default scheme changed or the older wallet was created with a non-default scheme.

3) Maybe they changed how they handle private keys that exceed the secp256k1 order. Ripple originally specified that a sequence number be increased and the seed re-hashed in this case (and this is what rippled does, look at the generateRootDeterminsticKey function). But one could argue that it's more natural to just fold the key. Maybe some implementations use the sequence approach and some the fold approach?

On the bright side, with all of these three possibilities, the funds are recoverable.

Link to comment
Share on other sites

  • 1 month later...
On 4/9/2017 at 6:49 AM, Mikedizzle said:

@enej found the issue and worked it all out, gatehub is awesome and at first I was worried and reluctant but they showed integrity, perserverance, and competency. Enej is the absolute man! Glad they worked it out though.



On 4/7/2017 at 2:46 PM, Mikedizzle said:

Somehow there are two ripple addresses attached to my secret key. I know this because I used desktop wallet and imported the secret key and it gave me a different address. I also tried importing my wallet to a new one in gatehub using the secret key and the address that has all the xrp is different from the address attached to the secret key. There is a glitch I just want my money safe. At this point I have tried the desktop wallet, ripple client and any other measure. I can't exchange to usd because it says invalid secret. Then I can't send funds because it says "disabled, watch only", I cannot connect trust lines, or connect to gateways. It seems to me that the secret key I was assigned is not the one assigned to my ripple address that has my funds, please reference the pictures. Any developers out there please help a brother out, it seems like gatehub is either busy or idk but they haven't got back to me about it in a while. 




@Mikedizzle I have the exact same issues. How long did @gatehub or @enej take to resolve it?

I sent an email on their support email and am waiting on a response from them since over a week now. Thanks

Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...