Jump to content

Is anyone else having issues with ilp-kit peers and payments?


Twarden
 Share

Recommended Posts

I just want to ask if anyone who has been working with the ilp-kit has been having a hard time creating trust-lines between peers?  I raised this issue a few hours ago and since then I haven't made much more progress with creating a trust-line or sending a test payment.  I was running this first instance of ilp-kit with my host name set to my IP, so I configured a domain and setup ilp-kit again using SSL with certbot (letsencrypt is mentioned in the setup, but apt-get cannot locate the package) then tried to establish a trust-lines again.  So far I've received the same error (TypeError: Cannot read property 'https://interledger.org/rel/publicKey' of undefined) several more times but I also received strange 'Unsupported currency' errors in the terminal some times without much more info than just that.  Also, if I try to send any payment to either of my test accounts from the admin, payment always fails because the admin's account balance is 0 instead of -1000 (the connector also did not start with 1000 units).

Link to comment
Share on other sites

  • Replies 7
  • Created
  • Last Reply

Top Posters In This Topic

24 minutes ago, mDuo13 said:

If it's anything like the five-bells-ledger, you might need to manually set the "minimum_allowed_balance" to "-infinity" (or some other very-negative number) on the admin account. I haven't used ilp-kit yet though.

This was an issue with the setup documentation instructing you to install postgresql 9.3 when you need at least 9.5; I upgraded to 9.6.2, wiped the database, recreated it, and the admin had -1000 units and the connector had 1000 so the issue was closed.

Link to comment
Share on other sites

  • 2 weeks later...

@Twarden If you need to add fund, you can use this short and easy code :P


curl -X PUT -H "Authorization: Basic  ADMIN:ADMINPASSWORDINBASE64" -H "Content-Type: application/json" -d '{"name": "username", "balance": "1000"}' https://ilpsitename/ledger/accounts/username

Example:

curl -X PUT -H "Authorization: Basic RtaW4YWRtaW46MmZRtaW4MmZ==" -H "Content-Type: application/json" -d '{"name": "winthanaung", "balance": "1000"}' https://usd.interledger.network/ledger/accounts/winthanaung

That will credit the user account :P, you can adjust balance the admin too. 


 

Link to comment
Share on other sites

9 hours ago, Twarden said:

@winthan Yes, I finally figured out why postgres got borked on ubuntu but no solution so far for my centos server.  My ilp-kit is running on https://royalcrypto.com for CAD but I will switch this to BTC once I have a chance to install the yahoo connector plugin.  By the way, don't you own https://ilp.milton.network?  

 

I own the interledger.network domain only. I am focusing on USD and Exotic currency pairs now.  Hope, I can come up with apps in 3 months soon. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.