Jump to content

Ripple Server always stop with no reason


Recommended Posts

My ripple server always stopped, I don't know the exact reason. Does anyone have the same problem here?

I choose Rocksdb, and the [ledger_history] is 10000000 ( about one year's data).

Here is my rippled.cnf:

#ssl_key = /etc/ssl/private/server.key
#ssl_cert = /etc/ssl/certs/server.crt

port = 5005
ip =
admin =
protocol = http

port = 51235
ip =
protocol = peer


port = 6006
ip =
admin =
protocol = ws

#port = 5005
#ip =
#protocol = wss



# This is primary persistent datastore for rippled.  This includes transaction
# metadata, account states, and ledger headers.  Helpful information can be
# found here: https://ripple.com/wiki/NodeBackEnd
# delete old ledgers while maintaining at least 2000. Do not require an
# external administrative command to initiate deletion.


# How many ledgers do we want to keep (history)?
# Integer value (ledger count)
# or (if you have lots of TB SSD storage): 'full'

# This is the persistent datastore for shards. It is important for the health
# of the ripple network that rippled operators shard as much as practical.
# NuDB requires SSD storage. Helpful information can be found here
# https://ripple.com/build/history-sharding


# This needs to be an absolute directory reference, not a relative one.
# Modify this value as required.


# Where to find some other servers speaking the Ripple protocol.
r.ripple.com 51235 51235 51235
s2.ripple.com 51235
# 51235
# 51235

# To use the XRP test network (see https://ripple.com/build/xrp-test-net/),
# use the following [ips] section instead:

# [ips]
# r.altnet.rippletest.net 51235

# File containing trusted validator keys or validator list publishers.
# Unless an absolute path is specified, it will be considered relative to the
# folder in which the rippled.cfg file is located.

# Turn down default logging to save disk space in the long run.
# Valid values here are trace, debug, info, warning, error, and fatal
{ "command": "log_level", "severity": "warning" }

# If ssl_verify is 1, certificates will be validated.
# To allow the use of self-signed certificates for development or internal use,
# set to ssl_verify to 0.

BTW, is the high IOPS (SSD) a must? What if I using sata?

Please help me out of here. Thank you all!


Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.