Jump to content

Mismatched valid address and key on gatehub wallet import


Recommended Posts

I created a public key (wallet address) and a private key (secret key) in a raspberry pi that has never been connected to the internet using the source code from well-know cold wallet address https://ihomp.github.io/ripply-paper-wallet/coldwallet-SHA1-cdfbe3260927b6073180a1099f02ef99ce0495e8.html

I wanted to make sure I knew that the secret generated by the wallet corresponded to its public key generated without burning 20 XRP and without exposing my secret to an exchange. So after reading around I found a post from "I_Hustle_Hard" in the below link (page 4 of thread) where he essentially says go to your gatehub account and try the import wallet screen, if you enter the right secret the submit button will be enabled, enter the wrong secret (even a character off) and it will not

So I did and it worked as the poster described. So far so good.

I then moved to another test, I generated 3 separate test wallets, each with their own public key (wallet address) and private key (secret key) and then tried to import a mismatched pair (for example public address of wallet 1 with secret of wallet 2 or 3) to my surprise gatehub allows me to import the wallet even though the pair is not a match.

Has someone tested this before and can explain why I am able to import a wallet to gatehub using a mismatched pair? I wanted to get some feedback from someone in the community that might know why this happened and the thread I originally replied to received only one response (thanks Xilobyte).

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Are you sure it's importing a mismatched pair? I would have thought that by specifying the secret key you are importing that you are merely importing the corresponding public address...

When you import does it ask for a public/ private pair? I don't see why it would even need the public address - the secret key should suffice.

Edited by Trippy
Link to comment
Share on other sites

You're right. It actually does import the correct address corresponding the to secret entered, the public address entered on purpose to create a mistmatch was entered in the wallet name textbox which is nothing more than a name and not the public address. I read the wallet import UI wrong.


Edited by gtyj
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...